March 09, 2005

Jcode 2.0 は Encode のラッパ

[ Perl ]
Jcode 2.0 より、お使いの Perl Version が 5.8.1 以降の場合は Encode の Wrapper として機能するようになりました。 この場合、Jcode.pm は付属モジュールを必要としないため、 jcode.pl の場合と同様、Jcode.pm を Library Path に置くだけで利用できるようになります。 それ以前のPerlをお使いの場合、Jcodeはver. 0.88と同じように機能します。

今日 shibuya-pm ML をぼーっと眺めていたら Jcode のバージョン2.0 は Encode のラッパとして機能するように作られているのを知りました。現在バージョン 1.99 が 2.0 の preview release という位置づけになってます。

Changes みてたのですが、1.99 の開発は先月中ごろから始まった様子、見逃してたなあ。

Encode::Guess で判定して Encode::encode や Encode::from_to で変換というのがなんか冗長でめんどくさく、いつもラッパを書いて使ってましたが、既存の Jcode の全機能がラッパとして提供されるのであれば、そんな手間も必要なくなりますね。

Posted by naoya at March 9, 2005 12:07 PM | トラックバック (0)  b_entry.gif
トラックバック [0件]
TrackBack URL: http://mt.bloghackers.net/mt/suck-tbspams.cgi/1501
コメント [0件]
コメントする









名前、アドレスを登録しますか?